<html>
<head>
<meta http-equiv="Content-Type" content="text/html;
charset=windows-1252">
</head>
<body>
<p>I agree with the opinion that the field should be available as
well on X3DShapeNode and X3DGroupingNode, but I think the logic
should be reversed: TRUE should mean ON/visible, and FALSE should
mean OFF/hidden. Better name the field 'visible' or even like
X3DOM 'render'. Think about interconnectivity, routing from one
exiting field to the new X3DShapeNode field, you could route a
TimeSensor's isActive or isPaused fields, or a TouchSensor's
isActive or isOver fields directly to the new field if the logic
is like above, to display for instance a 'lamp' shape to indicate
the action. This would not be possible if the field is named
'hidden' some logic would be need to negate the logic:
TimeSensor.isActive -> NOTScript -> Shape.hidden. With the
logic above, no Script node is needed.</p>
<p>Best regards,<br>
Holger<br>
</p>
<p><br>
</p>
<div class="moz-cite-prefix">On 13.12.19 12:17,
<a class="moz-txt-link-abbreviated" href="mailto:vmarchetti@kshell.com">vmarchetti@kshell.com</a> wrote:<br>
</div>
<blockquote type="cite"
cite="mid:F09A7810-35BF-4228-A466-C32B5C307ADD@kshell.com">
<meta http-equiv="Content-Type" content="text/html;
charset=windows-1252">
1. There is a extension attribute in X3DOM called the 'render'
attribute which serves this purpose, with opposite parity (meaning
render=true has the same effect as hidden=false). It is higher up
in the X3DOM inheritance tree, (see <a
href="https://doc.x3dom.org/author/Grouping/X3DBoundedObject.html"
class="" moz-do-not-send="true">https://doc.x3dom.org/author/Grouping/X3DBoundedObject.html</a> )
so it is an attribute in both the ShapeNode and the grouping
nodes.
<div class=""><br class="">
</div>
<div class="">2. To add this field to Shape, and potentially the
grouping nodes, we would need to specify how it behaves when the
Shape node is referenced multiple times in a Scene with DEF/USE
statements. This is a common pattern when a Shape is something
which is repeated multiple times, think tires on a car. However,
if 'hidden' is defined as a field on the Shape then all the
tires would be shown/hidden together, which may not be the
desired effect. If the authoring solution to avoid this is to
enclose each tire in its own Group node and apply hidden on that
Group, then you're pretty much back to the existing design
pattern available with the Switch node.<br class="">
<div><br class="">
</div>
<div>Vince Marchetti</div>
<div><br class="">
<blockquote type="cite" class="">
<div class="">On Dec 12, 2019, at 11:23 AM, Don Brutzman
<<a href="mailto:brutzman@nps.edu" class=""
moz-do-not-send="true">brutzman@nps.edu</a>> wrote:</div>
<br class="Apple-interchange-newline">
<div class="">
<div class="">A common task in 3D graphics is selectively
hiding geometry.<br class="">
<br class="">
X3D is fairly clumsy about this, typically requiring
Switch or LOD animation to achieve it.<br class="">
<br class="">
HTML has a much simpler approach, the 'hidden'
attribute. There is a similar construct in CSS.<br
class="">
<br class="">
<span class="Apple-tab-span" style="white-space:pre"> </span>HTML5
6.1 The hidden attribute<br class="">
<span class="Apple-tab-span" style="white-space:pre"> </span><a
href="https://html.spec.whatwg.org/multipage/interaction.html#the-hidden-attribute"
class="" moz-do-not-send="true">https://html.spec.whatwg.org/multipage/interaction.html#the-hidden-attribute</a><br
class="">
<br class="">
As a similar way to simplify hidding, either for pure
X3D or hybrid html/X3D, wondering if we might add a
'hidden' attribute to Shape.<br class="">
<br class="">
<span class="Apple-tab-span" style="white-space:pre"> </span>12.4.6
Shape<br class="">
<span class="Apple-tab-span" style="white-space:pre"> </span><a class="moz-txt-link-freetext" href="https://www.web3d.org/specifications/X3Dv4Draft/ISO-IEC19775-1v4-WD1/Part01/components/shape.html#Shape">https://www.web3d.org/specifications/X3Dv4Draft/ISO-IEC19775-1v4-WD1/Part01/components/shape.html#Shape</a><br
class="">
<br class="">
<span class="Apple-tab-span" style="white-space:pre"> </span>SFBool
[in out] hidden FALSE<br class="">
<br class="">
Might we add hidden to Shape? Is there a better
approach?<br class="">
<br class="">
all the best, Don<br class="">
-- <br class="">
Don Brutzman Naval Postgraduate School, Code USW/Br
<a class="moz-txt-link-abbreviated" href="mailto:brutzman@nps.edu">brutzman@nps.edu</a><br class="">
Watkins 270, MOVES Institute, Monterey CA 93943-5000
USA +1.831.656.2149<br class="">
X3D graphics, virtual worlds, navy robotics
<a class="moz-txt-link-freetext" href="http://faculty.nps.edu/brutzman">http://faculty.nps.edu/brutzman</a><br class="">
<br class="">
_______________________________________________<br
class="">
x3d-public mailing list<br class="">
<a class="moz-txt-link-abbreviated" href="mailto:x3d-public@web3d.org">x3d-public@web3d.org</a><br class="">
<a class="moz-txt-link-freetext" href="http://web3d.org/mailman/listinfo/x3d-public_web3d.org">http://web3d.org/mailman/listinfo/x3d-public_web3d.org</a><br
class="">
</div>
</div>
</blockquote>
</div>
<br class="">
</div>
<br>
<fieldset class="mimeAttachmentHeader"></fieldset>
<pre class="moz-quote-pre" wrap="">_______________________________________________
x3d-public mailing list
<a class="moz-txt-link-abbreviated" href="mailto:x3d-public@web3d.org">x3d-public@web3d.org</a>
<a class="moz-txt-link-freetext" href="http://web3d.org/mailman/listinfo/x3d-public_web3d.org">http://web3d.org/mailman/listinfo/x3d-public_web3d.org</a>
</pre>
</blockquote>
<pre class="moz-signature" cols="72">--
Holger Seelig
Digital Media Designer
Scheffelstraße 31a
04277 Leipzig
Germany
Cellular: +49 176 420 479 37
E-Mail: holger.seelig at create3000.de
Web: <a class="moz-txt-link-freetext" href="http://create3000.de">http://create3000.de</a></pre>
</body>
</html>