[X3D-Public] Mantis 525: Ecmascript method naming for inputOutput fields

Don Brutzman brutzman at nps.edu
Wed Jun 27 09:39:39 PDT 2012

Meeting today:  Len Daly, Dick Puk, Herbert Stocker, Don Brutzman

We discussed all alternatives today regarding how to resolve this issue.
Although the writeup is lengthy, diligently going through the details,

Problem statement: inputOutput field accessor methods need to have a different name than the field itself. Some javascript implementations confound the field object and the method object when the names are the same.

Fix summary:
a. Set methods for an inputOutput field shall be called set_fieldName.
b. Within the script, current value is referred to as fieldName.
c. If a fieldName is assigned from within the script, and if one or more outgoing routes are connected to the field, the last assigned value is sent over those routes after the function returns. The function set_fieldName is not called as a result of the script assigning its own inputOutput field.

Need to confirm that all browsers are matching this approach.  It would appear that there are no blockers to prevent success.

a. BitManagement will confirm whether and when they can implement.
b. We ask Fraunhofer to agree with (or improve) wording and have implemented the change.
c. We will confirm that Xj3D handles this correctly and fix if needed
d. support at octagavs.com has been informed
e. confirmation from freeWrl team and any other implementers will be gratefully received
f. view3dscene reports that this change helps them implement Javascript
g. X3D Validator and X3D Schematron rules will be modified to detect scripts with old style and recommend new style
h. Browsers might optionally parse script source code when loading and fix old-style references by text insertion of "set_" before any references
i. Dick, Len and Don will determine whether any further changes are needed for consistency with other related specification clauses
j. Concise specification changes will be posted for review and approval

Due to July 4 Independence Day holiday in USA, we plan to revisit the
issue next Tuesday July 3 (with X3D call replacing Dec3D call).

all the best, Don
Don Brutzman  Naval Postgraduate School, Code USW/Br       brutzman at nps.edu
Watkins 270,  MOVES Institute, Monterey CA 93943-5000 USA   +1.831.656.2149
X3D graphics, virtual worlds, navy robotics http://faculty.nps.edu/brutzman

More information about the X3D-Public mailing list