[x3d-public] editing x3d UPDATE

Don Brutzman brutzman at nps.edu
Wed Nov 4 07:45:05 PST 2015

cc: x3d-edit-developers

Alan, thank you very much for reporting this problem.  Sorry to cause problems.

Here are some initial modifications.

I've updated the script runX3dEditUnix.sh from a bash-ism to actual unix:

	source javaVersionCheck.sh

checked in at

I also improved the javaVersionCheck.sh script to be more descriptive.


If you can test them on your system, that would be great.

Surprising that the Netbeans plugin module didn't work for you... that has been plenty reliable.

The savage.nps.edu server has been suffering from intermittent power supply problems, we are looking to fix or move that host.  It is worth checking separately that you are getting a response from the server.

Will continue reviewing and addressing your reported issues.  Again thanks for trying things out.

On 11/2/2015 8:56 PM, Alan Grimes wrote:
> I made sure I had the latest jvm installed
>   java version "1.8.0_66"
> Here's the barf from clicking on a widget in netbeans:
> atg at tortoise ~ $ ./netbeans-8.0.1/bin/netbeans         << live updated
> since initial install, reports 8.0.2 on splash.
> Java HotSpot(TM) 64-Bit Server VM warning: ignoring option PermSize=32m;
> support was removed in 8.0
> #
> # A fatal error has been detected by the Java Runtime Environment:
> #
> #  SIGSEGV (0xb) at pc=0x00007f61435109bd, pid=20118, tid=140058790217472
> #
> # JRE version: Java(TM) SE Runtime Environment (8.0_66-b17) (build
> 1.8.0_66-b17)
> # Java VM: Java HotSpot(TM) 64-Bit Server VM (25.66-b17 mixed mode
> linux-amd64 compressed oops)
> # Problematic frame:
> # C  [libGL.so.1+0x539bd]
> #
> # Failed to write core dump. Core dumps have been disabled. To enable
> core dumping, try "ulimit -c unlimited" before starting Java again
> #
> # An error report file with more information is saved as:
> # /home/atg/hs_err_pid20118.log
> #
> # If you would like to submit a bug report, please visit:
> #   http://bugreport.java.com/bugreport/crash.jsp
> # The crash happened outside the Java Virtual Machine in native code.
> # See problematic frame for where to report the bug.
> #
> /home/atg/netbeans-8.0.1/platform/lib/nbexec: line 474: 20118
> Aborted                 "/etc/java-config-2/current-system-vm/bin/java"
> -Djdk.home="/etc/java-config-2/current-system-vm" -classpath
> "/home/atg/netbeans-8.0.1/platform/lib/boot.jar:/home/atg/netbeans-8.0.1/platform/lib/org-openide-modules.jar:/home/atg/netbeans-8.0.1/platform/lib/org-openide-util.jar:/home/atg/netbeans-8.0.1/platform/lib/org-openide-util-lookup.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/boot_ja.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/boot_pt_BR.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/boot_ru.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/boot_zh_CN.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-modules_ja.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-modules_pt_BR.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-modules_ru.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-modules_zh_CN.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-util_ja.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-util-lookup_ja.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-util-lookup_pt_BR.jar:/
>   me/atg/netbeans-8.0.1/platform/lib/locale/org-openide-util-lookup_ru.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-util-lookup_zh_CN.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-util_pt_BR.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-util_ru.jar:/home/atg/netbeans-8.0.1/platform/lib/locale/org-openide-util_zh_CN.jar:/etc/java-config-2/current-system-vm/lib/dt.jar:/etc/java-config-2/current-system-vm/lib/tools.jar"
> -Dnetbeans.default_userdir_root="/home/atg/.netbeans"
> -Dnetbeans.dirs="/home/atg/netbeans-8.0.1/nb:/home/atg/netbeans-8.0.1/ergonomics:/home/atg/netbeans-8.0.1/ide:/home/atg/netbeans-8.0.1/extide:/home/atg/netbeans-8.0.1/java:/home/atg/netbeans-8.0.1/apisupport:/home/atg/netbeans-8.0.1/webcommon:/home/atg/netbeans-8.0.1/websvccommon:/home/atg/netbeans-8.0.1/enterprise:/home/atg/netbeans-8.0.1/mobility:/home/atg/netbeans-8.0.1/profiler:/home/atg/netbeans-8.0.1/python:/home/atg/netbeans-8.0.1/php:/home/atg/netbeans-8.0.1/identity:/home/atg/netbeans-8.0.1/harness:/home/atg/netbeans-8.0.1/cnd:/home/atg/netbeans-8.0.1/dlight:/home/atg/netbeans-8.0.1/groovy:/home/atg/netbeans-8.0.1/extra:/home/atg/netbeans-8.0.1/javacard:/home/atg/netbeans-8.0.1/javafx:/home/atg/netbeans-8.0.1/x3dedit33:"
> -Dnetbeans.home="/home/atg/netbeans-8.0.1/platform"
> '-Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade'
> '-Dnetbeans.accept_license_class=org.netbeans.license.AcceptLicense'
> '-Xmx1024m' '-client' '-Xss2m' '-Xms32m' '-XX:PermSize=32m'
> '-Dapple.laf.useScreenMenuBar=true'
> '-Dapple.awt.graphics.UseQuartz=true' '-Dsun.java2d.noddraw=true'
> '-Dsun.java2d.dpiaware=true' '-Dsun.zip.disableMemoryMapping=true'
> -XX:+HeapDumpOnOutOfMemoryError
> -XX:HeapDumpPath="/home/atg/.netbeans/8.0.1/var/log/heapdump.hprof"
> org.netbeans.Main --cachedir "/home/atg/.cache/netbeans/8.0.1" --userdir
> "/home/atg/.netbeans/8.0.1" "--branding" "nb" 0<&0
> atg at tortoise ~ $ java --version

On 11/2/2015 8:51 PM, Alan Grimes wrote:
> I haz teh buk X3D "Extensible 3D graphics for web authors"...
> I tried blender but it was too sloppy for what I wanted to do. (create
> an under-construction page for my site with a rectangular solid with a
> logo on the front face and an e-mail address on the bottom face).
> I found mention that the book was using X3D edit for it's examples, so I
> tried to install it. Netbeans crashes whenever I try to use X3Dedit
> functions. (netbeans 8, java version "1.8.0_60").
> I decided to try x3dedit standalone.
> problem 1: the archive is a mess because it has many of the files in the
> root of the archive, common courtesy says that an archive should always
> include a directory so that it doesn't create a mess in the directory I
> use for all my "experimental" packages and self-written and/or compiled
> code....
> problem 2: it's call to javaversion check fails because it is not
> preceded by a "./"
> Problem 3: It couldn't find my java, I had to configure that manually,
> this is a common issue which is easy to fix, thankfully. On Gentoo, the
> correct directory is always: /etc/java-config-2/current-system-vm
> Problem 4 (showstopper): damn thing segfaults and basically either
> doesn't open, stays open for milliseconds, or crashes x'doze. =(
> Yeah, it basically doesn't work. =(((
> I have netbeans 8.02 or about that version... I really love netbeans in
> general... was trying version 3.3, there are many older versions and
> links to older versions still floating around too. =\

all the best, Don
Don Brutzman  Naval Postgraduate School, Code USW/Br       brutzman at nps.edu
Watkins 270,  MOVES Institute, Monterey CA 93943-5000 USA   +1.831.656.2149
X3D graphics, virtual worlds, navy robotics http://faculty.nps.edu/brutzman

More information about the x3d-public mailing list